home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / libsndfile-1.0.11 / libsndfile-1.0.11.ebuild < prev    next >
Text File  |  2005-12-20  |  1KB  |  40 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.11.ebuild,v 1.10 2005/07/12 05:04:39 geoman Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="A C library for reading and writing files containing sampled sound"
  8. HOMEPAGE="http://www.mega-nerd.com/libsndfile/"
  9. SRC_URI="http://www.mega-nerd.com/libsndfile/${P}.tar.gz"
  10.  
  11. LICENSE="LGPL-2.1"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 sparc x86"
  14. IUSE="static"
  15.  
  16. DEPEND="virtual/libc"
  17.  
  18. src_unpack() {
  19.     unpack ${A}
  20.     cd ${S}
  21.     epunt_cxx
  22. }
  23.  
  24. src_compile() {
  25.     econf $(use_enable static) || die "./configure failed"
  26.  
  27.     # fix this weird doc installation directory libsndfile decides
  28.     # to something more standard
  29.     sed -e "s:^htmldocdir.*:htmldocdir = /usr/share/doc/${PF}/html:" -i ${S}/doc/Makefile
  30.  
  31.     emake || die "emake failed"
  32. }
  33.  
  34. src_install() {
  35.     make DESTDIR="${D}" install || die "make install failed"
  36.     dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
  37. }
  38.  
  39. src_test() { :; }
  40.